什么原因导致 Microsoft SQL Server 2005 Express 不能被成功安装
说明:
WinCC flexible 2008 使用 Microsoft SQL Server 2005 Express 作为集成的数据库。该数据库默认情况下由 WinCC flexible 2008 ES 进行安装。
导致错误或损坏的数据库安装可能有多种原因。
如果安装或配置 Microsoft SQL Server 2005 Express 时失败或数据库损坏(诸如另外的安装),那么通常需要重新安装/重新配置 Microsoft SQL Server 2005 Express。
内容:
- MS SQL-Server 2005 Express 的安装问题
1.1 无法为 WinCC V7.0 安装 SQL Server
1.2 无法为 WinCC V6.2 安装 SQL Server
1.3 重装 SQL Server
- 使用 WinCC flexible 时 MS SQL-Server 2005 Express 数据库存在的问题
2.1 创建或者打开 WinCC flexible 项目被异常中止
2.2 创建或打开 WinCC flexible 工程时异常中止
通过远程桌面连接方式
1. Microsoft SQL Server 2005 Express 的安装问题
| 序号 |
操作过程 |
| 1.1 |
无法安装 WinCC V7.0 的 SQL Server
说明:
WinCC V7.0 SQL Server 无法安装。
可能原因: WinCC flexible 启动中心被启用了。
补救措施:
只能在 WinCC flexible 启动中心关闭的情况下安装 WinCC V7.0 SQL Server。
步骤:
- 在任务条的通知区域,任务条的“托盘”中右键单击图标
。
- 然后单击“自动启动 SIMATIC WinCC flexible >禁用”
|
| 1.2 |
无法为 WinCC V6.2 安装 SQL Server
说明:
无法安装 WinCC V6.2 SQL Server。
可能原因:
例如,其它 SQL 实例的影响
补救措施:
为了安装 WinCC V6.2 SQL Server,只能
卸载 Microsoft SQL Server 2005 Express 的 WinCC flexible 实例。
注意: 更详细的信息和操作提示请参见条目 ID: 30576253。 |
| 1.3 |
重新安装 SQL Server
说明: SQL Server 必须重新执行安装。
可能原因: 例如,其它 SQL 实例的影响
补救措施:
重新执行安装。
步骤:
- 插入安装 DVD。
- 运行 CD_1 目录中的“setup.exe”。
- 执行安装。
- 接受授权声明 - 但不要在其它对话框中更改预设值。
- 安装后重新启动计算机。
|
2. 已知存在的使用 WinCC flexible 时的 MS SQL Server 2005 Express 的问题
| 序号 |
操作过程 |
| 2.1 |
当创建或打开 WinCC flexible 项目时异常中止
说明:
创建或打开项目时弹出错误提示并异常中止。
注意:
也可参见2.2 使用远程桌面连接。
可能原因: Microsoft SQL Server 2005 Express 用户数据可能被损坏或者与已安装实例不匹配。
补救措施:
删除 WINCCFLEXEXPRESS 实例的用户数据的文件夹。
步骤:
- 关闭 WinCC flexible 2008。
- 右键单击任务条“通知区域”中的图标

,任务条的“托盘”区域。
- 然后单击“自动启动 SIMATIC WinCC flexible >禁用。”
- 打开 Windows 资源管理器。
- 在 Windows 资源管理器的地址栏,输入如下包含系统路径的路径并删除整个“WINCCFLEXEXPRESS”文件夹:
Windows XP:
%USERPROFILE%\Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\WINCCFLEXEXPRESS
或
%USERPROFILE%\Lokale Einstellungen\Anwendungsdaten\Microsoft\Microsoft SQL Server Data\WINCCFLEXEXPRESS
Windows Vista:
%USERPROFILE%\AppData\Local\Microsoft\Microsoft SQL Server Data\WINCCFLEXEXPRESS
  Fig. 01 - Environment-Variable + Pfad
注意:
使用系统变量“%USERPROFILE%”,可以根据登录用户打开相应的文件夹。
|
| 2.2 |
当通过远程桌面方式创建或打开 WinCC flexible 工程时异常中止
说明:
创建或打开工程时弹出错误消息并异常中止。
注意:
亦可参见2.1
可能原因:
Microsoft SQL Server 2005 Express 安装在基于 Windows XP SP2 系统的计算机上。用户试图获取远程访问。连接失败。
补救措施:
为操作系统安装相关的 Microsoft Hotfix。
步骤:
该错误可以使用 Microsoft Hotfix “KB896613”来修正。下载链接如下:
英文:http://support.microsoft.com/kb/896613/en-us
德语:http://support.microsoft.com/kb/896613/de |
关键词:
SQL Express